Large Scale Visualization with ParaView

ATPESC 2018

Dan Lipsa
Kitware, Inc.
Outline

• Kitware
• Introduction
• Basic Usage
• Visualizing Large Models
Kitware

• Computer Vision
• Data and Analytics
• HPC and Visualization
• Medical Computing
• Software Process
Kitware – Computer Vision
Kitware – Data and Analytics
Kitware – Software Process

- cmake, ctest, cdash
To Follow Along…

• Install ParaView 5.5.2
  – http://www.paraview.org ➔ Download
Introduction
What is ParaView?

• An open-source, scalable, multi-platform visualization application.
• Support for distributed computation models to process large data sets.
• An open, flexible, and intuitive user interface.
• An extensible, modular architecture based on open standards.
• A flexible BSD 3 Clause license
• Commercial maintenance and support.
ParaView on the Desktop
ParaView on the Web
Python scripts can control ParaView with or without the GUI in order to create reproducible and customizable visualizations.
ParaView Immersive
ParaView for HPC
Community Atmosphere Model (CAM5) 2D (PS) 3D data (T), Spectral Element dynamic module.
Visualization of 3D LIDAR data.
Current ParaView Usage

• Used by academic, government, and commercial institutions worldwide.
• Downloaded ~135K times per year.
• HPCwire Editors’ Choice 2010/2016 and HPCwire Readers’ Choice 2010/2012/2015 Awards for Best Visualization Product or Technology.
Data Ranges

• Used for all ranges of data size.

• Landmarks of usage:
  – 6 billion structured cells (2005).
  – Billions of AMR cells (2008).
  – Scaling test over 1 Trillion cells (2010).
  – 6.33 billion unstructured cells in Catalyst (2016).
ParaView Application Architecture

ParaView Client | pvpython | ParaWeb | Catalyst | Custom App

UI (Qt Widgets, Python Wrappings)

ParaView Server

VTK

OpenGL | MPI | IceT | Etc.
ParaView Development

- Started in 2000 as collaborative effort between Los Alamos National Laboratories and Kitware Inc. Sandia has been a major contributor since 2005.
  - ParaView 0.6 released October 2002.
  - GUI rewritten to be more user friendly and powerful.
- ParaView 4.0 released in June 2013.
  - Properties panel redesign for smoother interaction.
- ParaView 5.0 released in January 2016.
  - Updated to OpenGL 3.2 features. Huge performance improvements.
Current Funding

- ARL
- ERDC
- US Army (SBIR)
- US Air Force (STTR)
- ONR
- Support Contracts
  - Electricity de France
  - Microsoft
- Other contributors
  - Swiss National Supercomputing Centre
  - DOE SLAC
  - Ohio State
  - Mississippi State
  - RPI

This research was supported by the Exascale Computing Project (17-SC-20-SC), a collaborative effort of the U.S. Department of Energy Office of Science and the National Nuclear Security Administration.
Basics of Visualization
Data Types

Uniform Rectilinear (vtkImageData)

Non-Uniform Rectilinear (vtkRectilinearData)

Curvilinear (vtkStructuredData)

Polygonal (vtkPolyData)

Unstructured Grid (vtkUnstructuredGrid)

Multi-block
Hierarchical Adaptive Mesh Refinement (AMR)
Hierarchical Uniform AMR
Octree
More Information

• Help Menu
• *The ParaView Guide*
• Tutorials
• The ParaView web page
  – [www.paraview.org](http://www.paraview.org)
• ParaView discussion forum
  – [https://discourse.paraview.org/](https://discourse.paraview.org/)
Help Menu

- Getting Started with ParaView
- ParaView Guide
- Reader, Filter, and Writer Reference
- ParaView Tutorial
- Sandia National Labs Tutorials
- Example Visualizations
- ParaView Web Site
- ParaView Wiki
- ParaView Mailing Lists
- Release Notes
- Professional Support
- Professional Training
- Online Tutorials
- Online Blogs
- About...
Basic Usage
User Interface

- Menu Bar
- Toolbars
- Pipeline Browser
- Properties Panel
- Advanced Toggle

3D View
Getting Back GUI Components
Creating a Cylinder Source

1. Go to the Sources menu and select Cylinder.
2. Click the Apply button to accept the default parameters.
Simple Camera Manipulation

• Drag left, middle, right buttons for rotate, pan, zoom.
  – Also use Shift, Ctrl, Alt modifiers.
  – Also try holding down x, y, or z.
Creating a Cylinder Source

1. Go to the Source menu and select Cylinder.
2. Click the Apply button to accept the default parameters.
3. Increase the Resolution parameter.
4. Click the Apply button again.
Copy/Paste/Reset/Save Parameters

Properties (Cylinder1)

- Resolution: 6
- Height: 1
- Radius: 0.5
- Center: (0, 0, 0)
- Capping

Display (Geometry Representation)

- Representation: Surface
- Coloring: Solid Color
Display Properties

- **Representation**: Surface
- **Coloring**: Solid Color
- **Styling**: Opacity = 1
- **Lighting**: Specular = 0
Change Render Properties

1. Scroll down to the Display group.
2. Click the Edit button. (This button is replicated in the toolbar.)
3. Select a new color for the cylinder.
Render View Options

- View (Render)
- Edit Axes Grid
- Center Axes Visibility
- Orientation Axes
  - Orientation Axes Visibility
- Background
  - Single color
  - Color
  - Restore Default
Change Render Properties

1. Scroll down to the Display group.
2. Click the Edit button. (This button is replicated in the toolbar.)
3. Select a new color for the cylinder.
4. Scroll down to the View group.
5. Turn on the Axis Grid.
Advanced Properties

Search Properties

Toggle Advanced Properties
Searching Properties

1. Type “specular” in the properties search box
2. Change Specular value to 1 (makes the cylinder shiny)
Searching Properties

1. Type “specular” in the properties search box
2. Change Specular value to 1 (makes the cylinder shiny)

Other interesting properties:
• Axes Grid
• Opacity
• Lights
Using Auto Apply

1. Click Auto Apply.

2. Change the Resolution parameter again.

3. Note that the visualization automatically updates without having to hit Apply.
Changing the Color Palette

1. Make sure the orientation axes are visible in the lower left corner.

2. Click the color palette button and change the colors.

3. Try several color palettes.
Color Palettes

→ Edit Current Palette...
Undo Redo

Undo

Redo

Camera Undo

Camera Redo
Creating a Cylinder Source

1. Go to the Source menu and select Cylinder.
2. Click the Apply button to accept the default parameters.
3. Increase the Resolution parameter.
4. Click the Apply button again.
5. Delete the Cylinder.
Supported Data Types

- ParaView Data (.pvd)
- VTK (.vtp, .vtu, .vti, .vts, .vtr)
- VTK Legacy (.vtk)
- VTK Multi Block (.vtmb, .vtmg, .vthd, .vthb)
- Partitioned VTK (.pvtu, .pvti, .pvts, .pvtr)
- ADAPT (.nc, .cdf, .elev, .ncd)
- ANALYZE (.img, .hdr)
- ANSYS (.inp)
- AVS UCD (.inp)
- BOV (.bov)
- BYU (.g)
- CAM NetCDF (.nc, .ncdf)
- CCSM MTSD (.nc, .cdf, .elev, .ncd)
- CCSM STSD (.nc, .cdf, .elev, .ncd)
- CEAucd (.ucd, .inp)
- CGNS (.cgns)
- CMAT (.cmat)
- CML (.cml)
- CTRL (.ctrl)
- Chombo (.hdf5, .h5)
- Claw (.claw)
- Comma Separated Values (.csv)
- Cosmology Files (.cosmo, .gadget2)
- Curve2D (.curve, .ultra, .ult, .u)
- DDCMD (.ddcmd)
- Digital Elevation Map (.dem)
- Dyna3D (.dyn)
- EnSight (.case, .sos)
- Enzo boundary and hierarchy
- ExodusII (.g, .e, .exe, .ex2, .ex2v, etc)
- ExtrudedVol (.exvol)
- FVCOM (MTMD, MTSD, Particle, STSD)
- Facet Polygonal Data
- Flash multiblock files
- Fluent Case Files (.cas)
- Gaussian Cube File (.cube)
- JPEG Image (.jpg, .jpeg)
- LAMPPS Dump (.dump)
- LAMPPS Structure Files
- LODI (.nc, .cdf, .elev, .ncd)
- LODI Particle (.nc, .cdf, .elev, .ncd)
- LS-DYNA (.k, .lsdyna, .d3plot, .d3plot)
- M3DCI (.h5)
- MFIX Unstructured Grid (.RES)
- MM5 (.mm5)
- MPAS NetCDF (.nc, .ncdf)
- Meta Image (.mhd, .mha)
- Miranda (.mir, .raw)
- Multilevel 3d Plasma (.m3d, .h5)
- NASTRAN (.nas, .f06)
- Nek5000 Files
- Nrrd Raw Image (.nrrd, .nhdr)
- OpenFOAM Files (.foam)
- PATRAN (.neu)
- PFLOWTRAN (.h5)
- PLOT2D (.p2d)
- PLOT3D (.xyz, .q, .x, .vp3d)
- Ply Polygonal File Format
- PNG Image Files
- POP Ocean Files
- ParaDIS Files
- Phasta Files (.pht)
- Pixie Files (.h5)
- ProSTAR (.cel, .vrt)
- Protein Data Bank (.pdb, .ent, .pdb)
- Raw Image Files
- Raw NRRD image files (.nrrd)
- SAMRAI (.samrai)
- SAR (.sAR, .sar)
- SAS (.sasgeom, .sas, .sasdata)
- SESAME Tables
- SLAC netCDF mesh and mode data
- SLAC netCDF particle data
- Silo (.silo, .pdb)
- Spherical (.spherical, .sv)
- SpyPlot CTH
- SpyPlot (.case)
- SpyPlot History (.hscdh)
- Stereo Lithography (.stl)
- TIFF Files
- TSurf Files
- Tecplot ASCII (.tec, .tp)
- Tecplot Binary (.plt)
- Tetrad (.hdf5, .h5)
- UNIC (.h5)
- VASP CHGCA (.CHG)
- VASP OUT (.OUT)
- VASP POSTCAR (.POS)
- VPIC (.vpc)
- VRML (.wrl)
- Velodyne (.vld, .rst)
- VizSchema (.h5, .vsh5)
- Wavefront Polygonal Data (.obj)
- WindBlade (.wind)
- XDMF and hdf5 (.xmf, .xdmf)
- XMol Molecule
Custom Data Import: Prototype with Python

- A “programmable source” lets you program data readers right in the GUI.
- Uses wrappings for the basic VTK classes.
- Good for prototyping readers.

Custom Data Import: Plugin Containing a Reader

- Plugins: shared object libraries that can be dynamically loaded into ParaView.
- C++ code and XML description of the interface.
- Any VTK reader object can be added.
Custom Data Import: Python Reader/Filter Plugin

• Only available in releases greater than 5.5.2 or in the **nightly** binaries.

• Python code and python decorators description of the interface (similar with the XML description).

• [PythonAlgorithmExamples.py](#)
Load disk_out_ref.ex2

1. Open the file disk_out_ref.ex2 from the Examples directory.
Load disk_out_ref.ex2

1. Open the file disk_out_ref.ex2 from the Examples directory.

2. Load all data variables.

3. Click
Data Representation

- Toggle Color Legend
- Reset Scalar Range
- Reset Range Over All Time
- Mapped Variable
- Vector Component
- Representation

- Edit Colors
- Custom Scalar Range
- Scalar Range to Visible

- Examples of data visualization with different representations and settings.
Common Filters

- Calculator
- Contour
- Clip
- Slice
- Threshold
- Extract Subset
- Glyph
- Stream Tracer
- Warp (vector)
- Group Datasets
- Extract Level
Filters Menu

~ 150 filters
Quick Launch

- Used for searching for filters by name
- Keyboard shortcut
  - Ctrl-space for Windows & Linux
  - Alt-space for Mac
Apply a Filter

1. Make sure that disk_out_ref.ex2 is selected in the pipeline browser.

2. Select the contour filter.
Apply a Filter

3. Change parameters to create an isosurface at Temp = 400K.
Apply a Filter

1. Make sure that disk_out_ref.ex2 is selected in the pipeline browser.
2. Select the contour filter.
3. Change parameters to create an isosurface at Temp = 400K.
4. [Apply button]
Create a Cutaway Surface

1. Select `disk_out_ref.ex2` in the pipeline browser.
2. From the quick launch, select Extract Surface.
3. ![Apply Button]
Create a Cutaway Surface

1. Select disk_out_ref.ex2 in the pipeline browser.
2. From the quick launch, select Extract Surface.
3. Create a clip filter.
5. Apply
6. Apply
Pipeline Browser Structure

- disk_out_ref.ex2
  - Contour1
  - ExtractSurface1
    - Clip1
Pipeline Browser Structure

Disk out ref ex2

Contour1

ExtractSurface1

Clip1
Pipeline Browser Structure

Not Visible

**Pipeline Browser**
- disk_out_ref.ex2
- Contour1
- ExtractSurface1
- Clip1
Reset ParaView

Edit → Reset Session
Multiview
Multiview

1. Open disk_out_ref.ex2. Load all variables.
2. Add Clip filter.
4. 
5. Color surface by Pres.
Multiview

6. Split the view horizontally.
7. Make Clip1 visible.
Multiview

6. Split the view horizontally.
7. Make Clip1 visible.
9. Right-click view, Link Camera...
10. Click other view.
6. Split the view horizontally.
7. Make Clip1 visible.
9. Right-click view, Link Camera...
10. Click other view.
11. Click and zoom in a bit.
Modifying Views
Modifying Views
Reset ParaView

Edit → Reset Session
Streamlines

1. Open disk_out_ref.ex2. Load all variables.
2. Add Stream Tracer.
3. Change Seed Type to Point Source.
4. Uncheck Show Sphere.
5.
Streamlines

1. Open disk_out_ref.ex2. Load all variables.

2. Add Stream Tracer.

3. Change Seed Type to Point Source.

4. Uncheck Show Sphere.

5. 

6. From the quick launch, select Tube.

7. 

Apply

Show Sphere
Getting Fancy

10. Change Glyph Type to Cone.
11. Change Vectors to V.
12. Change Scale Mode to vector.
13. Click reset next to Scale Factor.
14. Apply
15. Color by Temp.
Getting Answers

• Where is the air moving the fastest? Near the disk or away from it? At the center of the disk or near its edges?
• Which way is the plate spinning?
• At the surface of the disk, is air moving toward the center or away from it?
Reset ParaView

Edit → Reset Session
Common Data Analysis Filters

- Extract Selection
- Plot Global Variables Over Time
- Plot Over Line
- Plot Selection Over Time
- Probe Location
Plotting

1. Open disk_out_ref.ex2. Load all variables.
2. Clip, uncheck, Show Plane.
3. Select disk_out_ref.ex2.
4. Add Plot Over Line filter.
3D Widgets
Placing 3D Line Widget Endpoints

• Use the p key to place alternating points.
  – Ctrl+p places at nearest mesh point.

• Use the 1 or 2 key to place the start or end point.
  – Ctrl+1 or Ctrl+2 places at mesh point.

• Drag the endpoints.
  – Use x, y, or z key to constrain to axis.

• Use widgets in Properties panel
  – E.g. Use Z Axis button and then edit points to place from (0,0,0) to (0, 0, 10).
Plotting

1. Open disk_out_ref.ex2. Load all variables.
2. Clip, uncheck, Show Plane.
3. Select disk_out_ref.ex2.
4. Add Plot Over Line filter.
5. Once line is satisfactorily located,
Interacting with Plots

• Left, middle, right buttons to pan, zoom.
• Mouse wheel to zoom.
• Reset view to plot ranges.
Plots are Views

- Move them like Views.
- Save screenshots.
Adjusting Plots

1. In Display section of properties panel, turn off all variables except Temp and Pres.
2. Select Pres in the Display options.
4. Verify the relationship between temperature and pressure.
Histogram / Bar Chart

1. Select disk_out_ref.ex2.
2. Filters → Data Analysis → Histogram
3. Change Input Array to Temp.
4. Apply
Histogram / Bar Chart
Reset ParaView

Edit → Reset Session
**Volume Rendering**

1. Open disk_out_ref.ex2. Load all variables.
2. Change variable viewed to Temp.
3. Change representation to Volume.
4. In the Are you sure dialog box, click Yes.
Volume Rendering + Surface Geometry

1. Open disk_out_ref.ex2. Load all variables.

2. Change variable viewed to Temp.

3. Change representation to Volume.


5. Optional: Add Tubes and Glyphs.
Transfer Function Editor
Modify Transfer Function

1. Select disk_out_ref.ex2.
2. Click Edit Color Map.
3. Click Choose preset.
   Apply. Close.
5. Try adding and changing control points.
Reset ParaView

Edit → Reset Session
Loading Data with Time

1. Open the file can.ex2.
2. Select all variables.
3. 
4. 
5. 

![Variables window with selected variables: Object Ids, Global Element Ids, EQPS, Global Node Ids, DISPL, VEL, ACCL, KE, XMOM, YMOM.](image)
Animation Toolbar

First Frame  Previous Frame  Play  Next Frame  Last Frame  Loop Animation  Current Time  Current Time Step

Time: 0.00429999  43 of 44
Animation Pitfall

1. Go to first time step.
2. Color by EQPS variable.
3. Play (or skip to last time step).
Animation Pitfall

1. Go to first time step.
2. Color by EQPS variable.
3. Play (or skip to last time step).
4. Fix with Rescale to Data Range.
Data Range Workarounds

• Go to representative time and hit

• In Settings change On File Open to Goto last timestep.
Data Range Workarounds

• Set a custom range.
Data Range Workarounds

• Rescale to range over all timesteps
Query-Based Selection

1. Open can.ex2. All variables.
2. Go to last time step.
3. Edit → Find Data.
4. Top combo box: find Cells.
5. Next row: EQPS, is ≥, and 1.5.
6. Click Run Selection Query.
Query-Based Selection
Brush Selection

- Surface Cell Selection (shortcut: s)
- Surface Point Selection (shortcut: d)
- Through Cell Selection (shortcut: f)
- Through Point Selection (shortcut: g)

- Select Cells (polygon)
- Select Points (polygon)
- Block Selection (shortcut: b)
- Interactively Select Cells
- Interactively Select Points
- Hover Point Query
- Hover Cell Query
Selections

1. Open Find Data.
2. Make various brush selections.
3. Observe results in the Find Data dialog box.
4. Play with the Invert Selection and Show Frustum options.
Adding Labels

1. Go to the last time step.
2. Open Find Data.
3. Create query Global ID is min. Click Run Selection Query.
4. In the Cell Labels chooser, select EQPS.
Adding Labels

1. Go to the last time step.
2. Open Find Data.
3. Create query Global ID is min. Click Run Selection Query.
4. In the Cell Labels chooser, select EQPS.
5. When you are done, turn off the EQPS labels.
Reset ParaView

Edit → Reset Session
Visualizing Large Models
Data Parallel Pipelines

• Duplicate pipelines run independently on different partitions of data.
Data Parallel Pipelines

- Many operations will work regardless.
  - Example: Clipping.
Data Parallel Pipelines

• Many operations will work regardless.
  – Example: Clipping.
Data Parallel Pipelines

• Many operations will work regardless.
  – Example: Clipping.

• Will discuss those that don’t later
Parallel Rendering
N component Data Parallelism for X GByte

MPI

Reader

Filter

Reader

Filter

Depth Composite

Client

Control, Display and Rendering of Small Data

Tile Display
ParaView’s Running Modes

<table>
<thead>
<tr>
<th>Built-in aka Standalone aka Serial</th>
<th>DS</th>
<th>RS</th>
<th>Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>all components within one process (client may be GUI or pvpython)</td>
<td>paraview</td>
<td>pvpython</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Combined Server</th>
<th>DS</th>
<th>RS</th>
<th>Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>data processing and parallel rendering in MPI job of combined processes. control from TCP connected client.</td>
<td>mpiexec -n x pvserver &amp;; paraview # or pvpython #+ Connect</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Batch</th>
<th>DS</th>
<th>RS</th>
<th>Client</th>
</tr>
</thead>
<tbody>
<tr>
<td>server is an MPI job which directly runs a python script</td>
<td>mpiexec -n x pvbatch \ vis_script.py</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

DS = data server
RS = render server
Fetch Server Configuration

- File > Connect > Fetch Servers
Connect Unix/Mac

**Mac Os**: Install Xquartz

![Connection Options for COOLEY@ANL](image_url)
Connect Windows

Windows: Install PuTTY
Memory Inspector
Advanced Data Parallel Pipelines

• Some operations will have problems.
  – Example: External Faces
Advanced Data Parallel Pipelines

• Ghost cells can solve most of these problems.
Advanced Data Parallel Pipelines

• Ghost cells can solve most of these problems.
Data Partitioning

• Partitions should be **load balanced** and spatially coherent. Why?
Data Partitioning

• Partitions should be **load balanced** and spatially coherent.
Data Partitioning

- Partitions should be load balanced and spatially coherent. A random partition with ghost cells will replicate the entire dataset on all nodes.
Load Balancing/Ghost Cells

- Automatic for Structured Meshes.
- Partitioning/ghost cells for unstructured is “manual.”
- Use Ghost Level Generator to create
- Legacy option: D3. Also repartitions
Thank you!

Questions?